Check engine version/en

Материал из Ace Stream
(Различия между версиями)
Перейти к: навигация, поиск
(Новая страница: «==Проверка версии движка с помощью javascript API== Иногда возникает необходимость проверки верс…»)
 
(Проверка версии движка с помощью javascript API)
Строка 1: Строка 1:
==Проверка версии движка с помощью javascript API==
+
==Check engine version using javascript API==
   
Иногда возникает необходимость проверки версии движка, установленного у пользователя. Например, вы создали трансляцию с помощью движка более новой версии, и эта трансляция не может быть просмотрена пользователями с более старыми версиями движка. В этом случае нужно проверить версию и при необходимости выдать пользователю сообщение с веб-страницы.
+
Sometimes it is necessary to check a version of installed engine. For example, you have created a broadcast using a newer version of the engine, and this broadcast can't be viewed by users with older versions of the engine. In this case it is necessary to check the version and if needed to warn users with a message from a web page.
   
Версию движка можно проверить на веб-странице с помощью javascript API.
+
You can checke engine version on a web page using javascript API.
   
Для проверки используется метод Player.getEngineVersion(), который возвращает строку с версией движка.
+
Method Player.getEngineVersion() is used for checking. It returns a string with engine version.
   
 
Узнать версию движка можно только после того, как на веб-страницу загрузился плагин Ace Stream P2P multimedia plugin. После завершения загрузки вызывается событие onLoad - именно в обработчике этого события нужно проверять версию.
 
Узнать версию движка можно только после того, как на веб-страницу загрузился плагин Ace Stream P2P multimedia plugin. После завершения загрузки вызывается событие onLoad - именно в обработчике этого события нужно проверять версию.

Версия 13:32, 22 сентября 2014

Check engine version using javascript API

Sometimes it is necessary to check a version of installed engine. For example, you have created a broadcast using a newer version of the engine, and this broadcast can't be viewed by users with older versions of the engine. In this case it is necessary to check the version and if needed to warn users with a message from a web page.

You can checke engine version on a web page using javascript API.

Method Player.getEngineVersion() is used for checking. It returns a string with engine version.

Узнать версию движка можно только после того, как на веб-страницу загрузился плагин Ace Stream P2P multimedia plugin. После завершения загрузки вызывается событие onLoad - именно в обработчике этого события нужно проверять версию.

Пример кода для получения версии движка:

<script type="text/javascript">
    var controls = new TorrentStream.Controls("player-div-id", {
        style: "internal"
    });

    try {
        var player = new TorrentStream.Player(controls.getPluginContainer(), {
                useInternalControls: true,
                onLoad: function() {
                    var engineVersion = this.getEngineVersion();
                    // check engine version here
                    this.registerEventHandler(controls);
                    controls.attachPlayer(this);
                    this.loadPlayer(contentId);
                }
        });
    }
    catch(e) {
        controls.onSystemMessage(e);
    }
 </script>

В данном примере вместо комментария check engine version here вы можете реализовать свою проверку версии.

Рабочий пример проверки версии можно посмотреть здесь: http://www.acestream.org/test/alpha.php. На данной странице запущена трансляция из-под движка версии 2.2.0 и стоит проверка на версию 2.2.х либо 3.х.х.

Персональные инструменты
На других языках